summaryrefslogtreecommitdiffstats
path: root/python/pytz
diff options
context:
space:
mode:
Diffstat (limited to 'python/pytz')
-rw-r--r--python/pytz/README5
-rw-r--r--python/pytz/pytz.SlackBuild83
-rw-r--r--python/pytz/pytz.info10
-rw-r--r--python/pytz/slack-desc19
4 files changed, 0 insertions, 117 deletions
diff --git a/python/pytz/README b/python/pytz/README
deleted file mode 100644
index 354f8ea02c..0000000000
--- a/python/pytz/README
+++ /dev/null
@@ -1,5 +0,0 @@
-pytz brings the Olson tz database into Python. This library allows
-accurate and cross platform timezone calculations using Python 2.3
-or higher. It also solves the issue of ambiguous times at the end
-of daylight savings, which you can read more about in the Python
-Library Reference (datetime.tzinfo).
diff --git a/python/pytz/pytz.SlackBuild b/python/pytz/pytz.SlackBuild
deleted file mode 100644
index 2d4da870cc..0000000000
--- a/python/pytz/pytz.SlackBuild
+++ /dev/null
@@ -1,83 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pytz
-
-# Copyright 2009-2021 Heinz Wiesinger, Amsterdam, The Netherlands
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pytz
-VERSION=${VERSION:-2021.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.txt PKG-INFO README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pytz/pytz.info b/python/pytz/pytz.info
deleted file mode 100644
index 6c4d2d5455..0000000000
--- a/python/pytz/pytz.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pytz"
-VERSION="2021.3"
-HOMEPAGE="https://launchpad.net/pytz"
-DOWNLOAD="https://files.pythonhosted.org/packages/e3/8e/1cde9d002f48a940b9d9d38820aaf444b229450c0854bdf15305ce4a3d1a/pytz-2021.3.tar.gz"
-MD5SUM="d7b7060bbac4970afa2050c139c9fcb6"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Heinz Wiesinger"
-EMAIL="pprkut@slackbuilds.org"
diff --git a/python/pytz/slack-desc b/python/pytz/slack-desc
deleted file mode 100644
index fcd51492e7..0000000000
--- a/python/pytz/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pytz: pytz (World timezone definitions for Python)
-pytz:
-pytz: pytz brings the Olson tz database into Python. This library allows
-pytz: accurate and cross platform timezone calculations using Python 2.3
-pytz: or higher. It also solves the issue of ambiguous times at the end
-pytz: of daylight savings, which you can read more about in the Python
-pytz: Library Reference (datetime.tzinfo).
-pytz:
-pytz: Homepage: https://launchpad.net/pytz
-pytz:
-pytz: