summaryrefslogtreecommitdiffstats
path: root/python/pytsk/pytsk.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pytsk/pytsk.SlackBuild')
-rw-r--r--python/pytsk/pytsk.SlackBuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/python/pytsk/pytsk.SlackBuild b/python/pytsk/pytsk.SlackBuild
index 38ed45a3a1..4c05ed9e1b 100644
--- a/python/pytsk/pytsk.SlackBuild
+++ b/python/pytsk/pytsk.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Slackware build script for pytsk
-# Copyright 2014 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2014-2015 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,10 +21,10 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Updated v 20141220 December 2014.
+# Updated v20150111 January 2015, Barry J. Grundy.
PRGNAM=pytsk
-VERSION=20141220
+VERSION=${VERSION:-20150111}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -65,8 +65,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tgz
cd $PRGNAM
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG