summaryrefslogtreecommitdiffstats
path: root/python/python3/patches/python3.x86_64.diff
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3/patches/python3.x86_64.diff')
-rw-r--r--python/python3/patches/python3.x86_64.diff12
1 files changed, 12 insertions, 0 deletions
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index d97019c544..31ea63fdab 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -100,6 +100,18 @@ diff -uar Python-3.3.0.orig/Lib/sysconfig.py Python-3.3.0/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
+diff -uar Python-3.3.0.orig/Lib/venv/__init__.py Python-3.3.0/Lib/venv/__init__.py
+--- Python-3.3.0.orig/Lib/venv/__init__.py 2012-09-29 11:00:40.000000000 +0300
++++ Python-3.3.0/Lib/venv/__init__.py 2013-02-10 13:29:16.859718301 +0200
+@@ -127,7 +127,7 @@
+ else:
+ binname = 'bin'
+ incpath = 'include'
+- libpath = os.path.join(env_dir, 'lib', 'python%d.%d' % sys.version_info[:2], 'site-packages')
++ libpath = os.path.join(env_dir, 'lib64', 'python%d.%d' % sys.version_info[:2], 'site-packages')
+ context.inc_path = path = os.path.join(env_dir, incpath)
+ create_if_needed(path)
+ create_if_needed(libpath)
diff -uar Python-3.3.0.orig/Makefile.pre.in Python-3.3.0/Makefile.pre.in
--- Python-3.3.0.orig/Makefile.pre.in 2012-09-29 11:00:41.000000000 +0300
+++ Python-3.3.0/Makefile.pre.in 2012-10-09 21:26:05.949858929 +0300