summaryrefslogtreecommitdiffstats
path: root/python/python3-url-normalize
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-url-normalize')
-rw-r--r--python/python3-url-normalize/README20
-rw-r--r--python/python3-url-normalize/python3-url-normalize.SlackBuild98
-rw-r--r--python/python3-url-normalize/python3-url-normalize.info10
-rw-r--r--python/python3-url-normalize/slack-desc19
4 files changed, 147 insertions, 0 deletions
diff --git a/python/python3-url-normalize/README b/python/python3-url-normalize/README
new file mode 100644
index 0000000000..348c60f001
--- /dev/null
+++ b/python/python3-url-normalize/README
@@ -0,0 +1,20 @@
+python3-url-normalize (URL normalization for Python)
+
+URI Normalization function:
+
+ -Take care of IDN domains.
+ -Always provide the URI scheme in lowercase characters.
+ -Always provide the host, if any, in lowercase characters.
+ -Only perform percent-encoding where it is essential.
+ -Always use uppercase A-through-F characters when percent-encoding
+ -Prevent dot-segments appearing in non-relative URI paths.
+ -For schemes that define a default authority, use an empty
+ authority if the default is desired.
+ -For schemes that define an empty path to be equivalent to a path
+ of "/", use "/".
+ -For schemes that define a port, use an empty port if the default
+ is desired
+ -All portions of the URI must be utf-8 encoded NFC from Unicode
+ strings
+
+Inspired by Sam Ruby's urlnorm.py
diff --git a/python/python3-url-normalize/python3-url-normalize.SlackBuild b/python/python3-url-normalize/python3-url-normalize.SlackBuild
new file mode 100644
index 0000000000..b99bad36fb
--- /dev/null
+++ b/python/python3-url-normalize/python3-url-normalize.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/bash
+
+# Slackware build script for python3-url-normalize
+
+# Copyright 2023 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-url-normalize
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-1.4.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+#change backend to poetry-core (1.4.3 is last version this is needed)
+sed -i -e "/^build-backend / s/poetry.masonry.api/poetry.core.masonry.api/" \
+ -e "/^requires / s/poetry>=0.12/poetry-core>=1.1.0/" pyproject.toml
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-url-normalize/python3-url-normalize.info b/python/python3-url-normalize/python3-url-normalize.info
new file mode 100644
index 0000000000..ca328fc115
--- /dev/null
+++ b/python/python3-url-normalize/python3-url-normalize.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-url-normalize"
+VERSION="1.4.3"
+HOMEPAGE="https://github.com/niksite/url-normalize"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/u/url-normalize/url-normalize-1.4.3.tar.gz"
+MD5SUM="3e72f94de0c4a98f8ea76cd99cf105d9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-poetry-core"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-url-normalize/slack-desc b/python/python3-url-normalize/slack-desc
new file mode 100644
index 0000000000..9d0d7aaed3
--- /dev/null
+++ b/python/python3-url-normalize/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-url-normalize: python3-url-normalize (URL normalization for Python)
+python3-url-normalize:
+python3-url-normalize: URL normalization for Python
+python3-url-normalize:
+python3-url-normalize: Homepage: https://github.com/niksite/url-normalize
+python3-url-normalize:
+python3-url-normalize:
+python3-url-normalize:
+python3-url-normalize:
+python3-url-normalize:
+python3-url-normalize: