summaryrefslogtreecommitdiffstats
path: root/python/python3-twisted/python3-twisted.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-twisted/python3-twisted.SlackBuild')
-rw-r--r--python/python3-twisted/python3-twisted.SlackBuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/python/python3-twisted/python3-twisted.SlackBuild b/python/python3-twisted/python3-twisted.SlackBuild
index cf7feee44d..ae16aff15b 100644
--- a/python/python3-twisted/python3-twisted.SlackBuild
+++ b/python/python3-twisted/python3-twisted.SlackBuild
@@ -23,14 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
# Originally written by Marco Bonetti - Thanks!
-# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
+# Then by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-twisted
-SRCNAM=Twisted
-VERSION=${VERSION:-22.4.0}
-BUILD=${BUILD:-1}
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-24.3.0}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -63,6 +63,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -83,7 +86,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
+
+# Fix initialization bug with zope.interface 6+
+sed -i 's#zope-interface#zope.interface#' $PKG/usr/lib*/python*/site-packages/twisted-${VERSION}.dist-info/METADATA
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true