summaryrefslogtreecommitdiffstats
path: root/python/python3-tox
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-tox')
-rw-r--r--python/python3-tox/README5
-rw-r--r--python/python3-tox/python3-tox.SlackBuild83
-rw-r--r--python/python3-tox/python3-tox.info10
-rw-r--r--python/python3-tox/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/python3-tox/README b/python/python3-tox/README
new file mode 100644
index 0000000000..5105e1c5cd
--- /dev/null
+++ b/python/python3-tox/README
@@ -0,0 +1,5 @@
+python3-tox (CLI CI frontend and development task automation tool)
+
+tox aims to automate and standardize testing in Python. It is part
+of a larger vision of easing the packaging, testing and release
+process of Python software (alongside pytest and devpi).
diff --git a/python/python3-tox/python3-tox.SlackBuild b/python/python3-tox/python3-tox.SlackBuild
new file mode 100644
index 0000000000..bdc47bcacf
--- /dev/null
+++ b/python/python3-tox/python3-tox.SlackBuild
@@ -0,0 +1,83 @@
+#!/bin/bash
+
+# Slackware build script for python3-tox
+
+# Copyright 2023-2024 Jeremy Hansen jebrhansen+SBo@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-tox
+VERSION=${VERSION:-4.15.0}
+SRCNAM=${SRCNAM:-tox}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir=$PKG dist/*.whl
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-tox/python3-tox.info b/python/python3-tox/python3-tox.info
new file mode 100644
index 0000000000..c016ff83ba
--- /dev/null
+++ b/python/python3-tox/python3-tox.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-tox"
+VERSION="4.15.0"
+HOMEPAGE="https://tox.wiki/"
+DOWNLOAD="https://github.com/tox-dev/tox/archive/refs/tags/4.15.0/tox-4.15.0.tar.gz"
+MD5SUM="913ef63e6b6fde79cf84d9126c2ee023"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-cachetools colorama python3-pyproject-api python3-virtualenv"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"
diff --git a/python/python3-tox/slack-desc b/python/python3-tox/slack-desc
new file mode 100644
index 0000000000..0e3047102f
--- /dev/null
+++ b/python/python3-tox/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-tox: python3-tox (CLI CI frontend and development task automation tool)
+python3-tox:
+python3-tox: tox aims to automate and standardize testing in Python. It is part
+python3-tox: of a larger vision of easing the packaging, testing and release
+python3-tox: process of Python software (alongside pytest and devpi).
+python3-tox:
+python3-tox: HOMEPAGE: https://tox.wiki/
+python3-tox:
+python3-tox:
+python3-tox:
+python3-tox: