summaryrefslogtreecommitdiffstats
path: root/python/python3-svglib
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-svglib')
-rw-r--r--python/python3-svglib/README6
-rw-r--r--python/python3-svglib/python3-svglib.SlackBuild100
-rw-r--r--python/python3-svglib/python3-svglib.info10
-rw-r--r--python/python3-svglib/slack-desc19
4 files changed, 135 insertions, 0 deletions
diff --git a/python/python3-svglib/README b/python/python3-svglib/README
new file mode 100644
index 0000000000..2f3ed2ecd3
--- /dev/null
+++ b/python/python3-svglib/README
@@ -0,0 +1,6 @@
+Used as a package you can read existing SVG files and convert them into
+ReportLab Drawing objects that can be used in a variety of contexts,
+e.g. as ReportLab Platypus Flowable objects or in RML. As a
+command-line tool it converts SVG files into PDF ones (but adding other
+output formats like bitmap or EPS is really easy and will be better
+supported, soon).
diff --git a/python/python3-svglib/python3-svglib.SlackBuild b/python/python3-svglib/python3-svglib.SlackBuild
new file mode 100644
index 0000000000..a951674881
--- /dev/null
+++ b/python/python3-svglib/python3-svglib.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/bash
+
+# Slackware build script for python3-svglib
+
+# Copyright 2022-2023 Nikos Giotis, Athens, GR
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-svglib
+SRCNAM=svglib
+VERSION=${VERSION:-1.5.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr/
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+rm -rf $PKG/usr/share
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG.rst LICENSE.txt README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-svglib/python3-svglib.info b/python/python3-svglib/python3-svglib.info
new file mode 100644
index 0000000000..e54db1cbca
--- /dev/null
+++ b/python/python3-svglib/python3-svglib.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-svglib"
+VERSION="1.5.1"
+HOMEPAGE="https://github.com/deeplook/svglib"
+DOWNLOAD="https://files.pythonhosted.org/packages/56/5b/53ca0fd447f73423c7dc59d34e523530ef434481a3d18808ff7537ad33ec/svglib-1.5.1.tar.gz"
+MD5SUM="31edde0d5873b2ee8b92731464061012"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-reportlab python3-lxml cssselect2"
+MAINTAINER="Nikos Giotis"
+EMAIL="nikos.giotis@gmail.com"
diff --git a/python/python3-svglib/slack-desc b/python/python3-svglib/slack-desc
new file mode 100644
index 0000000000..899a64c342
--- /dev/null
+++ b/python/python3-svglib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-svglib: python3-svglib (python library for reading and coverting SVG files)
+python3-svglib:
+python3-svglib: Svglib is a pure-Python library for reading SVG files and converting
+python3-svglib: them (to a reasonable degree) to other formats using the ReportLab
+python3-svglib: Open Source toolkit.
+python3-svglib:
+python3-svglib:
+python3-svglib:
+python3-svglib:
+python3-svglib:
+python3-svglib: