summaryrefslogtreecommitdiffstats
path: root/python/python3-statsmodels
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-statsmodels')
-rw-r--r--python/python3-statsmodels/README3
-rw-r--r--python/python3-statsmodels/python3-statsmodels.SlackBuild43
-rw-r--r--python/python3-statsmodels/python3-statsmodels.info10
3 files changed, 27 insertions, 29 deletions
diff --git a/python/python3-statsmodels/README b/python/python3-statsmodels/README
index c78c9034c4..9bb29c3006 100644
--- a/python/python3-statsmodels/README
+++ b/python/python3-statsmodels/README
@@ -6,3 +6,6 @@ plotting functions, and result statistics are available for
different types of data and each estimator. Researchers across
fields may find that statsmodels fully meets their needs for
statistical computing and data analysis in Python.
+
+python3-statsmodels 0.14.1 is the last available version for Slackware
+15.0. Newer versions would require Cython >= 3.0.10.
diff --git a/python/python3-statsmodels/python3-statsmodels.SlackBuild b/python/python3-statsmodels/python3-statsmodels.SlackBuild
index 6348d9e0c8..524e44afa1 100644
--- a/python/python3-statsmodels/python3-statsmodels.SlackBuild
+++ b/python/python3-statsmodels/python3-statsmodels.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-statsmodels
-# Copyright 2020-2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20231005 46and2: broken build, __version__ error on import, add
+# python3-setuptools-scm-opt as dep and set PYTHONPATH below to fix.
+# Change to pep517 build.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-statsmodels
-VERSION=${VERSION:-0.13.2}
+VERSION=${VERSION:-0.14.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +44,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,20 +53,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,18 +64,26 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# remove requirement
+sed -i '/oldest-supported-numpy/d' pyproject.toml
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
-python3 setup.py build
-python3 setup.py install --root=$PKG --optimize=1
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES.md CONTRIBUTING.rst COPYRIGHTS.txt LICENSE.txt README.rst README_l1.txt requirements*.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-statsmodels/python3-statsmodels.info b/python/python3-statsmodels/python3-statsmodels.info
index d5b8a9f3ab..10f49fa3a3 100644
--- a/python/python3-statsmodels/python3-statsmodels.info
+++ b/python/python3-statsmodels/python3-statsmodels.info
@@ -1,10 +1,10 @@
PRGNAM="python3-statsmodels"
-VERSION="0.13.2"
+VERSION="0.14.1"
HOMEPAGE="http://statsmodels.sourceforge.net/"
-DOWNLOAD="https://pypi.python.org/packages/source/s/statsmodels/statsmodels-0.13.2.tar.gz"
-MD5SUM="08d926aef96b97615a88e77c2dbf7f69"
+DOWNLOAD="https://pypi.python.org/packages/source/s/statsmodels/statsmodels-0.14.1.tar.gz"
+MD5SUM="4e0f1ecd898349d9f23ee496bb6ba7ba"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-pandas python3-patsy scipy3"
+REQUIRES="python3-pandas python3-patsy python3-scipy python3-setuptools-scm-opt"
MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+EMAIL="isaacyu@protonmail.com"