summaryrefslogtreecommitdiffstats
path: root/python/python3-statsmodels/python3-statsmodels.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-statsmodels/python3-statsmodels.SlackBuild')
-rw-r--r--python/python3-statsmodels/python3-statsmodels.SlackBuild45
1 files changed, 21 insertions, 24 deletions
diff --git a/python/python3-statsmodels/python3-statsmodels.SlackBuild b/python/python3-statsmodels/python3-statsmodels.SlackBuild
index 6348d9e0c8..48e6761ccb 100644
--- a/python/python3-statsmodels/python3-statsmodels.SlackBuild
+++ b/python/python3-statsmodels/python3-statsmodels.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-statsmodels
-# Copyright 2020-2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20231005 46and2: broken build, __version__ error on import, add
+# python3-setuptools-scm-opt as dep and set PYTHONPATH below to fix.
+# Change to pep517 build.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-statsmodels
-VERSION=${VERSION:-0.13.2}
+VERSION=${VERSION:-0.14.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +44,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,20 +53,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,18 +64,28 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# remove requirement
+sed -i '/oldest-supported-numpy/d' pyproject.toml
+
+# convert to minimum req'd instead of pinned
+sed -i 's/\(setuptools_scm.*\)~=/\1>=/' pyproject.toml
+
+export PYTHONPATH=/opt/python3.9/site-packages/
-python3 setup.py build
-python3 setup.py install --root=$PKG --optimize=1
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES.md CONTRIBUTING.rst COPYRIGHTS.txt LICENSE.txt README.rst README_l1.txt requirements*.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install