summaryrefslogtreecommitdiffstats
path: root/python/python3-seaborn
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-seaborn')
-rw-r--r--python/python3-seaborn/README6
-rw-r--r--python/python3-seaborn/python3-seaborn.SlackBuild22
-rw-r--r--python/python3-seaborn/python3-seaborn.info10
3 files changed, 13 insertions, 25 deletions
diff --git a/python/python3-seaborn/README b/python/python3-seaborn/README
index c11a97b528..2364d99803 100644
--- a/python/python3-seaborn/README
+++ b/python/python3-seaborn/README
@@ -1,6 +1,6 @@
Seaborn is a Python data visualization library based on matplotlib.
-It provides a high-level interface for drawing attractive and
+It provides a high-level interface for drawing attractive and
informative statistical graphics.
-python3-statsmodels (optional) provides advanced statistical
-plot functions.
+python3-scipy and python3-statsmodels (both optional) provide advanced
+statistical plot functions.
diff --git a/python/python3-seaborn/python3-seaborn.SlackBuild b/python/python3-seaborn/python3-seaborn.SlackBuild
index abb48f95bd..bac7684b82 100644
--- a/python/python3-seaborn/python3-seaborn.SlackBuild
+++ b/python/python3-seaborn/python3-seaborn.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-seaborn
-# Copyright 2020-2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-seaborn
-VERSION=${VERSION:-0.11.2}
+VERSION=${VERSION:-0.13.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,16 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
-else
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,13 +64,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md requirements.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-seaborn/python3-seaborn.info b/python/python3-seaborn/python3-seaborn.info
index 1ce4289eb5..979abf8768 100644
--- a/python/python3-seaborn/python3-seaborn.info
+++ b/python/python3-seaborn/python3-seaborn.info
@@ -1,10 +1,10 @@
PRGNAM="python3-seaborn"
-VERSION="0.11.2"
+VERSION="0.13.2"
HOMEPAGE="https://seaborn.pydata.org/"
-DOWNLOAD="https://github.com/mwaskom/seaborn/archive/v0.11.2/seaborn-0.11.2.tar.gz"
-MD5SUM="2c73097c1c48af26587b65499d559b10"
+DOWNLOAD="https://github.com/mwaskom/seaborn/archive/v0.13.2/seaborn-0.13.2.tar.gz"
+MD5SUM="5e18d5141b2c7db84948e64a8076ab09"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-matplotlib python3-pandas scipy3"
+REQUIRES="python3-matplotlib python3-pandas"
MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+EMAIL="isaacyu@protonmail.com"