summaryrefslogtreecommitdiffstats
path: root/python/python3-reportlab
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-reportlab')
-rw-r--r--python/python3-reportlab/README23
-rw-r--r--python/python3-reportlab/python3-reportlab.SlackBuild82
-rw-r--r--python/python3-reportlab/python3-reportlab.info10
-rw-r--r--python/python3-reportlab/slack-desc19
4 files changed, 134 insertions, 0 deletions
diff --git a/python/python3-reportlab/README b/python/python3-reportlab/README
new file mode 100644
index 0000000000..43391124d9
--- /dev/null
+++ b/python/python3-reportlab/README
@@ -0,0 +1,23 @@
+The ReportLab Open Source PDF library is a proven industry-strength
+python-based PDF generating solution, suitable for web publishers,
+developers or creative design professionals who need to quickly and
+easily create or automate complex (even data-driven) documents.
+It is released by ReportLab Inc., under BSD license.
+
+It includes binary extensions (previously available separately)
+_rl_accel and renderPM
+
+It has the following features:
+- create professional portable documents
+- real document layout engine (Platypus)
+- flowable objects (paragraphs headlines tables images graphics etc)
+- arbitrary Type-1 fonts
+- bitmap images, vector graphics
+- library of reusable primitive shapes
+- extensible widget library
+- layered architecture
+- includes simple demos and more complex tools
+- allows for any data sources
+- strong community support
+- platform-independent
+- includes PythonPoint - PDF Presentation Tool
diff --git a/python/python3-reportlab/python3-reportlab.SlackBuild b/python/python3-reportlab/python3-reportlab.SlackBuild
new file mode 100644
index 0000000000..4216cfb977
--- /dev/null
+++ b/python/python3-reportlab/python3-reportlab.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/bash
+
+# Slackware build script for python3-reportlab
+
+# Copyright 2022-2024 Vijay Marcel
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-reportlab
+VERSION=${VERSION:-4.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+PYNAM=${PYNAM:-reportlab}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+trap 'echo "$0 FAILED at line $LINENO!" | tee -a $OUTPUT/error-${PRGNAM}.log' ERR
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+rm -rf $PYNAM-$VERSION
+tar xvf $CWD/$PYNAM-$VERSION.tar.gz
+cd $PYNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs CHANGES.md LICENSE README.txt VERSION.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \+
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-reportlab/python3-reportlab.info b/python/python3-reportlab/python3-reportlab.info
new file mode 100644
index 0000000000..79c9f7cb0f
--- /dev/null
+++ b/python/python3-reportlab/python3-reportlab.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-reportlab"
+VERSION="4.2.0"
+HOMEPAGE="https://reportlab.com"
+DOWNLOAD="https://pypi.org/packages/source/r/reportlab/reportlab-4.2.0.tar.gz"
+MD5SUM="83aa69a14f3450cd8e84e376d8713436"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Vijay Marcel"
+EMAIL="vijaymarcel@outlook.com"
diff --git a/python/python3-reportlab/slack-desc b/python/python3-reportlab/slack-desc
new file mode 100644
index 0000000000..f1fc80a89f
--- /dev/null
+++ b/python/python3-reportlab/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-reportlab: python3-reportlab (Python3 Reportlab Toolkit)
+python3-reportlab:
+python3-reportlab: The reportlab toolkit. An opensource python library
+python3-reportlab: for generating PDF and graphics.This package
+python3-reportlab: provides the python3 module.
+python3-reportlab:
+python3-reportlab: Homepage:https://reportlab.com
+python3-reportlab:
+python3-reportlab:
+python3-reportlab:
+python3-reportlab: