summaryrefslogtreecommitdiffstats
path: root/python/python3-pythran
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pythran')
-rw-r--r--python/python3-pythran/python3-pythran.SlackBuild24
-rw-r--r--python/python3-pythran/python3-pythran.info10
2 files changed, 17 insertions, 17 deletions
diff --git a/python/python3-pythran/python3-pythran.SlackBuild b/python/python3-pythran/python3-pythran.SlackBuild
index 24754f626b..7c5911061b 100644
--- a/python/python3-pythran/python3-pythran.SlackBuild
+++ b/python/python3-pythran/python3-pythran.SlackBuild
@@ -1,7 +1,8 @@
#!/bin/bash
# Slackware build script for python3-pythran
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+#
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pythran
-VERSION=${VERSION:-0.11.0}
+VERSION=${VERSION:-0.15.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,17 +49,14 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+# Only LIBDIRSUFFIX is used within the SlackBuild
if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
- SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
@@ -80,16 +75,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Needs newer setuptools
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
# Remove bundled boost and xsimd
-rm -r $PKG/usr/lib$LIBDIRSUFFIX/python*/site-packages/pythran/{boost,xsimd}
+rm -r $PKG/usr/lib*/python$PYVER/site-packages/pythran/{boost,xsimd}
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS Changelog LICENSE PKG-INFO README.rst requirements.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS Changelog README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-pythran/python3-pythran.info b/python/python3-pythran/python3-pythran.info
index 65f013caba..b57720bc0c 100644
--- a/python/python3-pythran/python3-pythran.info
+++ b/python/python3-pythran/python3-pythran.info
@@ -1,10 +1,10 @@
PRGNAM="python3-pythran"
-VERSION="0.11.0"
+VERSION="0.15.0"
HOMEPAGE="https://pythran.readthedocs.io/en/latest/"
-DOWNLOAD="https://files.pythonhosted.org/packages/88/9f/161f08131abf7f23920cee29b691de27f10fd97ac09fb2f3532b3a7f9b96/pythran-0.11.0.tar.gz"
-MD5SUM="e09e90484771937ab499380858bdb18d"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pythran/pythran-0.15.0.tar.gz"
+MD5SUM="cc6fa05e583733182d06d2e41e03cc10"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-beniget numpy3 xsimd pytest-runner"
+REQUIRES="python3-beniget python3-numpy python3-setuptools-opt xsimd"
MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+EMAIL="isaacyu@protonmail.com"