summaryrefslogtreecommitdiffstats
path: root/python/python3-pytest/python3-pytest.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pytest/python3-pytest.SlackBuild')
-rw-r--r--python/python3-pytest/python3-pytest.SlackBuild28
1 files changed, 8 insertions, 20 deletions
diff --git a/python/python3-pytest/python3-pytest.SlackBuild b/python/python3-pytest/python3-pytest.SlackBuild
index d4b78e1b2c..325292f333 100644
--- a/python/python3-pytest/python3-pytest.SlackBuild
+++ b/python/python3-pytest/python3-pytest.SlackBuild
@@ -3,7 +3,8 @@
# Slackware build script for python3-pytest
# Copyright 2018 Serban Udrea <S.Udrea@gsi.de>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
# Based on the pytest SlackBuild by Dimitris Zlatanidis Orestiada, Greece
#
@@ -28,7 +29,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pytest
SRCNAM=pytest
-VERSION=${VERSION:-7.1.3}
+VERSION=${VERSION:-8.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -53,20 +51,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -82,7 +66,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Use newer setuptools
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
mv $PKG/usr/bin/py.test $PKG/usr/bin/py.test3
mv $PKG/usr/bin/pytest $PKG/usr/bin/pytest3