summaryrefslogtreecommitdiffstats
path: root/python/python3-pydantic-core
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pydantic-core')
-rw-r--r--python/python3-pydantic-core/README4
-rw-r--r--python/python3-pydantic-core/mkvendored.sh17
-rw-r--r--python/python3-pydantic-core/python3-pydantic-core.SlackBuild122
-rw-r--r--python/python3-pydantic-core/python3-pydantic-core.info12
-rw-r--r--python/python3-pydantic-core/slack-desc19
5 files changed, 174 insertions, 0 deletions
diff --git a/python/python3-pydantic-core/README b/python/python3-pydantic-core/README
new file mode 100644
index 0000000000..9164bfacf7
--- /dev/null
+++ b/python/python3-pydantic-core/README
@@ -0,0 +1,4 @@
+python3-pydantic-core (provides the core functionality for pydantic)
+
+This package provides the core functionality for pydantic validation
+and serialization.
diff --git a/python/python3-pydantic-core/mkvendored.sh b/python/python3-pydantic-core/mkvendored.sh
new file mode 100644
index 0000000000..c52093378e
--- /dev/null
+++ b/python/python3-pydantic-core/mkvendored.sh
@@ -0,0 +1,17 @@
+#!/bin/bash
+
+# This is a wrapper script for cargo-mkvendored.sh which is
+# included in the cargo-vendor-filterer slackbuild and needs to be
+# installed. It is only needed if you are upgrading the version and
+# need new vendored rust libs.
+#
+# create $PRGNAM-vendored-sources-$VERSION-$VSBUILD.tar.xz
+# requires network access, but does not require root privilege.
+# requires that $PRGNAM's REQUIRES need to be installed first
+
+if [ -f /usr/bin/cargo-mkvendored.sh ]; then
+ /usr/bin/cargo-mkvendored.sh
+else
+ echo " ERROR: cargo-mkvendored.sh script is not available!!
+ ERROR: Install the cargo-vendor-filterer slackbuild."
+fi
diff --git a/python/python3-pydantic-core/python3-pydantic-core.SlackBuild b/python/python3-pydantic-core/python3-pydantic-core.SlackBuild
new file mode 100644
index 0000000000..1aa67afa8c
--- /dev/null
+++ b/python/python3-pydantic-core/python3-pydantic-core.SlackBuild
@@ -0,0 +1,122 @@
+#!/bin/bash
+
+# Slackware build script for python3-pydantic-core
+
+# Copyright 2023-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# 20240102 46and2: Use VSBUILD for vendored sources
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-pydantic-core
+SRCNAM=pydantic_core
+VERSION=${VERSION:-2.18.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+VSBUILD=${VSBUILD:-1}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z
+tar xvf $CWD/$SRCNAM-vendored-sources-$VERSION-$VSBUILD.tar.?z
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# remove .cargo line from Cargo.toml, breaks using vendored libs
+sed -i '/^ "\/.cargo",$/d' Cargo.toml
+
+# prevent cargo from using the network.
+# this only works because we have a vendored sources tarball with
+# everything cargo would have downloaded.
+export CARGO_NET_OFFLINE=true
+
+# prevent cargo from writing outside of $TMP
+export CARGO_HOME=$(pwd)/.cargo
+
+export PATH="/opt/rust16/bin:$PATH"
+if [ -z "$LD_LIBRARY_PATH" ]; then
+ export LD_LIBRARY_PATH="/opt/rust16/lib$LIBDIRSUFFIX"
+else
+ export LD_LIBRARY_PATH="/opt/rust16/lib$LIBDIRSUFFIX:$LD_LIBRARY_PATH"
+fi
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-pydantic-core/python3-pydantic-core.info b/python/python3-pydantic-core/python3-pydantic-core.info
new file mode 100644
index 0000000000..f793a3e89c
--- /dev/null
+++ b/python/python3-pydantic-core/python3-pydantic-core.info
@@ -0,0 +1,12 @@
+PRGNAM="python3-pydantic-core"
+VERSION="2.18.2"
+HOMEPAGE="https://github.com/pydantic/pydantic-core"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pydantic-core/pydantic_core-2.18.2.tar.gz \
+ https://slackware.uk/~fourtysixandtwo/src/pydantic_core-vendored-sources-2.18.2-1.tar.xz"
+MD5SUM="ab1cb4e3ca6029712348b78cd7dff507 \
+ a09f26d30c01d8b60192cb86980d071e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-maturin python3-hatchling"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-pydantic-core/slack-desc b/python/python3-pydantic-core/slack-desc
new file mode 100644
index 0000000000..17ba04949c
--- /dev/null
+++ b/python/python3-pydantic-core/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-pydantic-core: python3-pydantic-core (provides the core functionality for pydantic)
+python3-pydantic-core:
+python3-pydantic-core: This package provides the core functionality for pydantic validation
+python3-pydantic-core: and serialization.
+python3-pydantic-core:
+python3-pydantic-core:
+python3-pydantic-core:
+python3-pydantic-core:
+python3-pydantic-core: Homepage: https://github.com/pydantic/pydantic-core
+python3-pydantic-core:
+python3-pydantic-core: