summaryrefslogtreecommitdiffstats
path: root/python/python3-pdm/python3-pdm.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-pdm/python3-pdm.SlackBuild')
-rw-r--r--python/python3-pdm/python3-pdm.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/python/python3-pdm/python3-pdm.SlackBuild b/python/python3-pdm/python3-pdm.SlackBuild
index b88c8d712e..ad4b992ea7 100644
--- a/python/python3-pdm/python3-pdm.SlackBuild
+++ b/python/python3-pdm/python3-pdm.SlackBuild
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pdm
-VERSION=${VERSION:-2.13.3}
+VERSION=${VERSION:-2.14.0}
SRCNAM=${SRCNAM:-pdm}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -62,6 +62,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Remove unused dependency (used for redistributable builds of python)
+sed -i '/\"pbs-installer\[install\]\",/d' pyproject.toml
+
python3 -m build --wheel --no-isolation
python3 -m installer --destdir=$PKG dist/*.whl