summaryrefslogtreecommitdiffstats
path: root/python/python3-openpyxl/python3-openpyxl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-openpyxl/python3-openpyxl.SlackBuild')
-rw-r--r--python/python3-openpyxl/python3-openpyxl.SlackBuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/python/python3-openpyxl/python3-openpyxl.SlackBuild b/python/python3-openpyxl/python3-openpyxl.SlackBuild
index 2981e56fac..e14195e3a7 100644
--- a/python/python3-openpyxl/python3-openpyxl.SlackBuild
+++ b/python/python3-openpyxl/python3-openpyxl.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-openpyxl
-# Copyright 2020-2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020-2023 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-openpyxl
-VERSION=${VERSION:-3.0.10}
+VERSION=${VERSION:-3.1.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -77,8 +74,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py build
-python3 setup.py install --skip-build --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true