summaryrefslogtreecommitdiffstats
path: root/python/python3-matplotlib-inline
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-matplotlib-inline')
-rw-r--r--python/python3-matplotlib-inline/python3-matplotlib-inline.SlackBuild38
-rw-r--r--python/python3-matplotlib-inline/python3-matplotlib-inline.info12
2 files changed, 26 insertions, 24 deletions
diff --git a/python/python3-matplotlib-inline/python3-matplotlib-inline.SlackBuild b/python/python3-matplotlib-inline/python3-matplotlib-inline.SlackBuild
index ea22be40d8..3b0561cd84 100644
--- a/python/python3-matplotlib-inline/python3-matplotlib-inline.SlackBuild
+++ b/python/python3-matplotlib-inline/python3-matplotlib-inline.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for python3-matplotlib-inline
-# Copyright 2021-2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2021-2022 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,13 +26,12 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-matplotlib-inline
-VERSION=${VERSION:-0.1.6}
+SRCNAM=matplotlib_inline
+VERSION=${VERSION:-0.1.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCNAM=matplotlib-inline
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,16 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
-else
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,7 +64,22 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Fix version detection
+export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+
+# Use newer python packages in /opt/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+# Add unused section to avoid ERROR message from setuptools_scm
+# Make it an if statement just in case upstream decides to update
+# it and I don't notice.
+if ! grep -qF "[tool.setuptools_scm]" pyproject.toml; then
+ echo "[tool.setuptools_scm]" >> pyproject.toml
+fi
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-matplotlib-inline/python3-matplotlib-inline.info b/python/python3-matplotlib-inline/python3-matplotlib-inline.info
index 4135cf2823..66b8129b3a 100644
--- a/python/python3-matplotlib-inline/python3-matplotlib-inline.info
+++ b/python/python3-matplotlib-inline/python3-matplotlib-inline.info
@@ -1,10 +1,10 @@
PRGNAM="python3-matplotlib-inline"
-VERSION="0.1.6"
+VERSION="0.1.7"
HOMEPAGE="https://github.com/ipython/matplotlib-inline"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/m/matplotlib-inline/matplotlib-inline-0.1.6.tar.gz"
-MD5SUM="aded9a57e2f526f76b3a4851d5528d4f"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/m/matplotlib-inline/matplotlib_inline-0.1.7.tar.gz"
+MD5SUM="96fe871bf30dc414e6724423c1e2ebb1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="traitlets"
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+REQUIRES="traitlets python3-setuptools-opt python3-matplotlib"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"