summaryrefslogtreecommitdiffstats
path: root/python/python3-marisa-trie/python3-marisa-trie.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-marisa-trie/python3-marisa-trie.SlackBuild')
-rw-r--r--python/python3-marisa-trie/python3-marisa-trie.SlackBuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/python/python3-marisa-trie/python3-marisa-trie.SlackBuild b/python/python3-marisa-trie/python3-marisa-trie.SlackBuild
index 15417683bd..97e1fa963e 100644
--- a/python/python3-marisa-trie/python3-marisa-trie.SlackBuild
+++ b/python/python3-marisa-trie/python3-marisa-trie.SlackBuild
@@ -25,11 +25,11 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-marisa-trie
-VERSION=${VERSION:-1.1.0}
+VERSION=${VERSION:-1.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCNAM=${SRCNAM:-marisa-trie}
+SRCNAM=${SRCNAM:-marisa_trie}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -49,13 +49,13 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-march=i586 -mtune=i686 -pipe -O2 -fPIC"
+ SLKCFLAGS="-march=i586 -mtune=i686 -pipe -O2"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-march=i686 -mtune=i686 -pipe -O2 -fPIC"
+ SLKCFLAGS="-march=i686 -mtune=i686 -pipe -O2"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-march=x86-64 -mtune=generic -pipe -O2 -fPIC"
+ SLKCFLAGS="-march=x86-64 -mtune=generic -pipe -O2"
LIBDIRSUFFIX="64"
elif [ "$ARCH" = "aarch64" ]; then
SLKCFLAGS="-O2 -fPIC"
@@ -82,12 +82,12 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
+CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ | cut -f 1 -d : | xargs strip --strip-unneeded --remove-section=.comment --remove-section=.note 2> /dev/null || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -pv $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS.rst CHANGES.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \+