summaryrefslogtreecommitdiffstats
path: root/python/python3-kiwisolver
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-kiwisolver')
-rw-r--r--python/python3-kiwisolver/README2
-rw-r--r--python/python3-kiwisolver/python3-kiwisolver.SlackBuild19
-rw-r--r--python/python3-kiwisolver/python3-kiwisolver.info10
3 files changed, 16 insertions, 15 deletions
diff --git a/python/python3-kiwisolver/README b/python/python3-kiwisolver/README
index 539a84662d..b35df7080d 100644
--- a/python/python3-kiwisolver/README
+++ b/python/python3-kiwisolver/README
@@ -7,4 +7,4 @@ the original Cassowary solver with typical use cases gaining a 40x
improvement. Memory savings are consistently > 5x.
This is the Python 3 version of kiwisolver and will coexist with SBo's
-kiwisolver package.
+python2-kiwisolver package.
diff --git a/python/python3-kiwisolver/python3-kiwisolver.SlackBuild b/python/python3-kiwisolver/python3-kiwisolver.SlackBuild
index 390af3b7d3..53c78d794e 100644
--- a/python/python3-kiwisolver/python3-kiwisolver.SlackBuild
+++ b/python/python3-kiwisolver/python3-kiwisolver.SlackBuild
@@ -3,7 +3,8 @@
# Slackware build script for python3-kiwisolver
# Copyright 2018 Serban Udrea <s.udrea@gsi.de>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification,
@@ -28,7 +29,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-kiwisolver
SRCNAM=kiwisolver
-VERSION=${VERSION:-1.4.3}
+VERSION=${VERSION:-1.4.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,16 +42,13 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$PRGNAM}
+PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -e
@@ -68,10 +66,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Workaround - ensure egg.info folder is named kiwisolver-1.4.3-py3.9-egg.info
-sed -i "/setup(/a \ \ name=\'kiwisolver\'," setup.py
+# Use newer, non-stock setuptools due to package requirements
+# Requres python/python3-setuptools-opt build-time dependency
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
-python3 setup.py install --root $PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-kiwisolver/python3-kiwisolver.info b/python/python3-kiwisolver/python3-kiwisolver.info
index 9d67f3b53c..f54bac9c1f 100644
--- a/python/python3-kiwisolver/python3-kiwisolver.info
+++ b/python/python3-kiwisolver/python3-kiwisolver.info
@@ -1,10 +1,10 @@
PRGNAM="python3-kiwisolver"
-VERSION="1.4.3"
+VERSION="1.4.5"
HOMEPAGE="https://github.com/nucleic/kiwi"
-DOWNLOAD="https://github.com/nucleic/kiwi/releases/download/1.4.3/kiwisolver-1.4.3.tar.gz"
-MD5SUM="73a4e57c33ded99dbe9a5cabca5be04b"
+DOWNLOAD="https://github.com/nucleic/kiwi/releases/download/1.4.5/kiwisolver-1.4.5.tar.gz"
+MD5SUM="20dea6992699d6be8a563995d7fe0309"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="cppy"
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"