summaryrefslogtreecommitdiffstats
path: root/python/python3-guessit
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-guessit')
-rw-r--r--python/python3-guessit/python3-guessit.SlackBuild27
-rw-r--r--python/python3-guessit/python3-guessit.info6
2 files changed, 8 insertions, 25 deletions
diff --git a/python/python3-guessit/python3-guessit.SlackBuild b/python/python3-guessit/python3-guessit.SlackBuild
index 012bbeb466..c3fab6db97 100644
--- a/python/python3-guessit/python3-guessit.SlackBuild
+++ b/python/python3-guessit/python3-guessit.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-guessit
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-guessit
-SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
-VERSION=${VERSION:-3.4.3}
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-3.8.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -76,9 +59,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/python3-guessit/python3-guessit.info b/python/python3-guessit/python3-guessit.info
index 9900d26af7..5125d75335 100644
--- a/python/python3-guessit/python3-guessit.info
+++ b/python/python3-guessit/python3-guessit.info
@@ -1,8 +1,8 @@
PRGNAM="python3-guessit"
-VERSION="3.4.3"
+VERSION="3.8.0"
HOMEPAGE="http://guessit.readthedocs.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/g/guessit/guessit-3.4.3.tar.gz"
-MD5SUM="6be580bad4dec4d31ec0137810ef821a"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/g/guessit/guessit-3.8.0.tar.gz"
+MD5SUM="5a488b3a1fb0e8df0a5b9af8eb336209"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-babelfish python3-rebulk python3-dateutil"