summaryrefslogtreecommitdiffstats
path: root/python/python3-fontMath/python3-fontMath.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-fontMath/python3-fontMath.SlackBuild')
-rw-r--r--python/python3-fontMath/python3-fontMath.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/python3-fontMath/python3-fontMath.SlackBuild b/python/python3-fontMath/python3-fontMath.SlackBuild
index e0360355d6..e8404e6db7 100644
--- a/python/python3-fontMath/python3-fontMath.SlackBuild
+++ b/python/python3-fontMath/python3-fontMath.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-fontMath
-# Copyright 2022 Duncan Roe, Melbourne, Australia
+# Copyright 2022-2024 Duncan Roe, Melbourne, Australia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-fontMath
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-0.9.1}
+VERSION=${VERSION:-0.9.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -52,6 +52,7 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -e
+trap 'echo "$0 FAILED at line $LINENO!" | tee -a $OUTPUT/error-${PRGNAM}.log' ERR
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -66,7 +67,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a License.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION