summaryrefslogtreecommitdiffstats
path: root/python/python3-cheroot/python3-cheroot.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-cheroot/python3-cheroot.SlackBuild')
-rw-r--r--python/python3-cheroot/python3-cheroot.SlackBuild27
1 files changed, 7 insertions, 20 deletions
diff --git a/python/python3-cheroot/python3-cheroot.SlackBuild b/python/python3-cheroot/python3-cheroot.SlackBuild
index 37bbafe3f2..42572eef31 100644
--- a/python/python3-cheroot/python3-cheroot.SlackBuild
+++ b/python/python3-cheroot/python3-cheroot.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-cheroot
-# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-cheroot
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-10.0.0}
+VERSION=${VERSION:-10.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -50,23 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "aarch64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -82,7 +65,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true