summaryrefslogtreecommitdiffstats
path: root/python/python3-boto3
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-boto3')
-rw-r--r--python/python3-boto3/README7
-rw-r--r--python/python3-boto3/python3-boto3.SlackBuild80
-rw-r--r--python/python3-boto3/python3-boto3.info10
-rw-r--r--python/python3-boto3/slack-desc19
4 files changed, 116 insertions, 0 deletions
diff --git a/python/python3-boto3/README b/python/python3-boto3/README
new file mode 100644
index 0000000000..c246d39573
--- /dev/null
+++ b/python/python3-boto3/README
@@ -0,0 +1,7 @@
+Boto3 is the Amazon Web Services (AWS) Software Development Kit (SDK)
+for Python, which allows Python developers to write software that
+makes use of services like Amazon S3 and Amazon EC2. You can find the
+latest, most up to date, documentation at `Read the Docs`_, including
+a list of services that are supported.
+
+This is the Python 3 build of boto3.
diff --git a/python/python3-boto3/python3-boto3.SlackBuild b/python/python3-boto3/python3-boto3.SlackBuild
new file mode 100644
index 0000000000..3343badbf5
--- /dev/null
+++ b/python/python3-boto3/python3-boto3.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/bash
+
+# Slackware build script for python3-boto3
+
+# Copyright 2023-2024 Isaac Yu <isaacyu@protonmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-boto3
+VERSION=${VERSION:-1.34.14}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=boto3
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.rst CODE_OF_CONDUCT.md CONTRIBUTING.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-boto3/python3-boto3.info b/python/python3-boto3/python3-boto3.info
new file mode 100644
index 0000000000..6d013d3d68
--- /dev/null
+++ b/python/python3-boto3/python3-boto3.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-boto3"
+VERSION="1.34.14"
+HOMEPAGE="https://aws.amazon.com/sdk-for-python/"
+DOWNLOAD="https://github.com/boto/boto3/archive/1.34.14/boto3-1.34.14.tar.gz"
+MD5SUM="3f35d2664447ec738ac8d5284077edd1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="s3transfer"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"
diff --git a/python/python3-boto3/slack-desc b/python/python3-boto3/slack-desc
new file mode 100644
index 0000000000..7dc202653b
--- /dev/null
+++ b/python/python3-boto3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-boto3: python3-boto3 (Python API for AWS)
+python3-boto3:
+python3-boto3: Boto is the Amazon Web Services (AWS) Software Development Kit (SDK)
+python3-boto3: for Python, which allows Python developers to write software that
+python3-boto3: makes use of services like Amazon S3 and Amazon EC2. You can find the
+python3-boto3: latest, most up to date, documentation at `Read the Docs`_, including
+python3-boto3: a list of services that are supported.
+python3-boto3:
+python3-boto3: Homepage: http://aws.amazon.com/sdk-for-python/
+python3-boto3:
+python3-boto3: