summaryrefslogtreecommitdiffstats
path: root/python/python3-blessed
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-blessed')
-rw-r--r--python/python3-blessed/README14
-rw-r--r--python/python3-blessed/python3-blessed.SlackBuild100
-rw-r--r--python/python3-blessed/python3-blessed.info10
-rw-r--r--python/python3-blessed/slack-desc19
4 files changed, 143 insertions, 0 deletions
diff --git a/python/python3-blessed/README b/python/python3-blessed/README
new file mode 100644
index 0000000000..11891981bf
--- /dev/null
+++ b/python/python3-blessed/README
@@ -0,0 +1,14 @@
+Blessed is an easy, practical library for making terminal apps, by
+providing an elegant, well-documented interface to Colors, Keyboard
+input, and screen position and Location capabilities.
+
+It’s meant to be fun and easy, to do basic terminal graphics and
+styling with Python using blessed. Terminal is the only class you need
+to import and the only object you should need for Terminal
+capabilities.
+
+Whether you want to improve CLI apps with colors, or make fullscreen
+applications or games, blessed should help get you started quickly.
+Your users will love it because it works on Windows, Mac, and Linux,
+and you will love it because it has plenty of documentation and
+examples!
diff --git a/python/python3-blessed/python3-blessed.SlackBuild b/python/python3-blessed/python3-blessed.SlackBuild
new file mode 100644
index 0000000000..08a9311e90
--- /dev/null
+++ b/python/python3-blessed/python3-blessed.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/bash
+
+# Slackware build script for python3-blessed
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-blessed
+TARNAM=blessed
+VERSION=${VERSION:-1.20.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+
+rm -rf $TARNAM-$VERSION
+tar xvf $CWD/$TARNAM-$VERSION.tar.gz
+cd $TARNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-blessed/python3-blessed.info b/python/python3-blessed/python3-blessed.info
new file mode 100644
index 0000000000..eccaa4c41e
--- /dev/null
+++ b/python/python3-blessed/python3-blessed.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-blessed"
+VERSION="1.20.0"
+HOMEPAGE="https://pypi.org/project/blessed/"
+DOWNLOAD="https://files.pythonhosted.org/packages/25/ae/92e9968ad23205389ec6bd82e2d4fca3817f1cdef34e10aa8d529ef8b1d7/blessed-1.20.0.tar.gz"
+MD5SUM="a640803116e0273f3ef1178626cb6282"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-blessed_2023-11-30@lockywolf.net"
diff --git a/python/python3-blessed/slack-desc b/python/python3-blessed/slack-desc
new file mode 100644
index 0000000000..b83266d088
--- /dev/null
+++ b/python/python3-blessed/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-blessed: python3-blessed (library for making terminal apps)
+python3-blessed:
+python3-blessed: Easy, practical library for making terminal apps, by providing an
+python3-blessed: elegant, well-documented interface to Colors, Keyboard input, and
+python3-blessed: screen Positioning capabilities.
+python3-blessed:
+python3-blessed:
+python3-blessed:
+python3-blessed:
+python3-blessed:
+python3-blessed: