summaryrefslogtreecommitdiffstats
path: root/python/python3-babel/python3-babel.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-babel/python3-babel.SlackBuild')
-rw-r--r--python/python3-babel/python3-babel.SlackBuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/python/python3-babel/python3-babel.SlackBuild b/python/python3-babel/python3-babel.SlackBuild
index 9d7fe28dda..b732a3a722 100644
--- a/python/python3-babel/python3-babel.SlackBuild
+++ b/python/python3-babel/python3-babel.SlackBuild
@@ -73,6 +73,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Apply upstream patches for python >= 3.9
+for i in $CWD/patches/* ; do patch -p1 < $i ; done
+
ln -s $CWD/core.zip cldr/cldr-core-$CLDRVER.zip
python3 setup.py import_cldr
python3 setup.py install --root=$PKG