summaryrefslogtreecommitdiffstats
path: root/python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild')
-rw-r--r--python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild33
1 files changed, 8 insertions, 25 deletions
diff --git a/python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild b/python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild
index acdc4fc203..c086862cae 100644
--- a/python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild
+++ b/python/python3-Flask-RESTX/python3-Flask-RESTX.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-Flask-RESTX
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-Flask-RESTX
-SRCNAM=$(echo ${PRGNAM,,} | sed "s/python3-//")
-VERSION=${VERSION:-0.5.1}
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-1.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,34 +48,20 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
+rm -rf ${SRCNAM,,}-$VERSION
+tar xvf $CWD/${SRCNAM,,}-$VERSION.tar.gz
+cd ${SRCNAM,,}-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG