summaryrefslogtreecommitdiffstats
path: root/python/python3-Flask-Dance/python3-Flask-Dance.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-Flask-Dance/python3-Flask-Dance.SlackBuild')
-rw-r--r--python/python3-Flask-Dance/python3-Flask-Dance.SlackBuild31
1 files changed, 8 insertions, 23 deletions
diff --git a/python/python3-Flask-Dance/python3-Flask-Dance.SlackBuild b/python/python3-Flask-Dance/python3-Flask-Dance.SlackBuild
index 6c412d46ee..ac987d4839 100644
--- a/python/python3-Flask-Dance/python3-Flask-Dance.SlackBuild
+++ b/python/python3-Flask-Dance/python3-Flask-Dance.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-Flask-Dance
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,12 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# 20220512 46and2: Updated version to support newer Flask and werkzeug.
+# 20221015 46and2: Updated version, change build process.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-Flask-Dance
-SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
-VERSION=${VERSION:-6.1.1}
+SRCNAM=flask_dance
+VERSION=${VERSION:-7.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -53,20 +51,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -78,11 +62,12 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true