summaryrefslogtreecommitdiffstats
path: root/python/python3-Flask-Compress
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-Flask-Compress')
-rw-r--r--python/python3-Flask-Compress/python3-Flask-Compress.SlackBuild16
-rw-r--r--python/python3-Flask-Compress/python3-Flask-Compress.info6
2 files changed, 11 insertions, 11 deletions
diff --git a/python/python3-Flask-Compress/python3-Flask-Compress.SlackBuild b/python/python3-Flask-Compress/python3-Flask-Compress.SlackBuild
index 954bc752a7..5862cb1540 100644
--- a/python/python3-Flask-Compress/python3-Flask-Compress.SlackBuild
+++ b/python/python3-Flask-Compress/python3-Flask-Compress.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-Flask-Compress
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,8 +28,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-Flask-Compress
-SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
-VERSION=${VERSION:-1.12}
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-1.14}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -42,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -63,6 +60,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -79,9 +79,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/python3-Flask-Compress/python3-Flask-Compress.info b/python/python3-Flask-Compress/python3-Flask-Compress.info
index 3c9dabbbba..cb0f903347 100644
--- a/python/python3-Flask-Compress/python3-Flask-Compress.info
+++ b/python/python3-Flask-Compress/python3-Flask-Compress.info
@@ -1,8 +1,8 @@
PRGNAM="python3-Flask-Compress"
-VERSION="1.12"
+VERSION="1.14"
HOMEPAGE="https://github.com/colour-science/flask-compress"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-compress/Flask-Compress-1.12.tar.gz"
-MD5SUM="0c59298b90788e4d3a88349e165ac42c"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-compress/Flask-Compress-1.14.tar.gz"
+MD5SUM="bd5ea440033b7f89464c1e0b56074795"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="Flask"