summaryrefslogtreecommitdiffstats
path: root/python/python2-automat
diff options
context:
space:
mode:
Diffstat (limited to 'python/python2-automat')
-rw-r--r--python/python2-automat/README5
-rw-r--r--python/python2-automat/python2-automat.SlackBuild98
-rw-r--r--python/python2-automat/python2-automat.info10
-rw-r--r--python/python2-automat/slack-desc19
4 files changed, 0 insertions, 132 deletions
diff --git a/python/python2-automat/README b/python/python2-automat/README
deleted file mode 100644
index 5d089cfa07..0000000000
--- a/python/python2-automat/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Automat is a library for concise, idiomatic Python expression of
-finite-state automata (particularly deterministic finite-state
-transducers).
-
-python-m2r is an optional dependency for better documentations.
diff --git a/python/python2-automat/python2-automat.SlackBuild b/python/python2-automat/python2-automat.SlackBuild
deleted file mode 100644
index 61aa580355..0000000000
--- a/python/python2-automat/python2-automat.SlackBuild
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python2-automat
-#
-# Copyright 2021 Yth | Pont-en-Royans, France | yth@ythogtha.org
-# Copyright 2017-2018 Markus Reichelt, Aachen, DE
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python2-automat
-SRCNAM=Automat
-VERSION=${VERSION:-20.2.0}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -ar LICENSE README.* docs/ $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-automat/python2-automat.info b/python/python2-automat/python2-automat.info
deleted file mode 100644
index d9aa4d7bb8..0000000000
--- a/python/python2-automat/python2-automat.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python2-automat"
-VERSION="20.2.0"
-HOMEPAGE="https://pypi.python.org/pypi/Automat"
-DOWNLOAD="https://pypi.python.org/packages/source/A/Automat/Automat-20.2.0.tar.gz"
-MD5SUM="d6cef9886b037b8857bfbc686f3ae30a"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-setuptools-scm python2-attrs wheel"
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/python/python2-automat/slack-desc b/python/python2-automat/slack-desc
deleted file mode 100644
index 989849d87d..0000000000
--- a/python/python2-automat/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python2-automat: python2-automat (Self-service finite-state machines)
-python2-automat:
-python2-automat: https://pypi.python.org/pypi/Automat
-python2-automat:
-python2-automat:
-python2-automat:
-python2-automat:
-python2-automat:
-python2-automat:
-python2-automat:
-python2-automat: