summaryrefslogtreecommitdiffstats
path: root/python/python-neovim/python-neovim.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-neovim/python-neovim.SlackBuild')
-rw-r--r--python/python-neovim/python-neovim.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/python/python-neovim/python-neovim.SlackBuild b/python/python-neovim/python-neovim.SlackBuild
index 6c6db7fdc3..9eac8c1035 100644
--- a/python/python-neovim/python-neovim.SlackBuild
+++ b/python/python-neovim/python-neovim.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-neovim
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-neovim
SRCNAM=python-client
-VERSION=${VERSION:-0.2.4}
+VERSION=${VERSION:-0.2.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,9 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true