summaryrefslogtreecommitdiffstats
path: root/python/python-nbxmpp/python-nbxmpp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-nbxmpp/python-nbxmpp.SlackBuild')
-rw-r--r--python/python-nbxmpp/python-nbxmpp.SlackBuild31
1 files changed, 8 insertions, 23 deletions
diff --git a/python/python-nbxmpp/python-nbxmpp.SlackBuild b/python/python-nbxmpp/python-nbxmpp.SlackBuild
index 917524014b..5563f6b22d 100644
--- a/python/python-nbxmpp/python-nbxmpp.SlackBuild
+++ b/python/python-nbxmpp/python-nbxmpp.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for python-nbxmpp
# Copyright 2014-2022 Ruben Schuller
+# Copyright 2022-2023 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,10 +26,9 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-nbxmpp
-VERSION=${VERSION:-2.0.6}
+VERSION=${VERSION:-3.2.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-TARNAM=${PRGNAM}-nbxmpp
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,28 +48,14 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $TARNAM-$VERSION
-tar xvf $CWD/$TARNAM-$VERSION.tar.gz
-cd $TARNAM-$VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -80,7 +63,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true