summaryrefslogtreecommitdiffstats
path: root/python/python-libnacl/python-libnacl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-libnacl/python-libnacl.SlackBuild')
-rw-r--r--python/python-libnacl/python-libnacl.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/python/python-libnacl/python-libnacl.SlackBuild b/python/python-libnacl/python-libnacl.SlackBuild
index 0e1a5769e7..9d8bf85b81 100644
--- a/python/python-libnacl/python-libnacl.SlackBuild
+++ b/python/python-libnacl/python-libnacl.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-libnacl
-# Copyright 2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2014-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-libnacl
SRCNAM=libnacl
-VERSION=${VERSION:-1.4.0}
+VERSION=${VERSION:-1.4.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -65,14 +65,14 @@ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
+if [ "${PYTHON3:-no}" == "yes" ]; then
python3 setup.py install --root=$PKG
fi