summaryrefslogtreecommitdiffstats
path: root/python/python-jeepney
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-jeepney')
-rw-r--r--python/python-jeepney/python-jeepney.SlackBuild9
-rw-r--r--python/python-jeepney/python-jeepney.info8
2 files changed, 8 insertions, 9 deletions
diff --git a/python/python-jeepney/python-jeepney.SlackBuild b/python/python-jeepney/python-jeepney.SlackBuild
index 13396855e5..17c20a2f4a 100644
--- a/python/python-jeepney/python-jeepney.SlackBuild
+++ b/python/python-jeepney/python-jeepney.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for python-jeepney
# Copyright 2021 Andrew Clemons, Wellington New Zealand
+# Copyright 2023 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-jeepney
SRCNAM=jeepney
-VERSION=${VERSION:-0.7.1}
+VERSION=${VERSION:-0.8.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,7 +78,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-jeepney/python-jeepney.info b/python/python-jeepney/python-jeepney.info
index 0fee0965e1..d7c23e5ca7 100644
--- a/python/python-jeepney/python-jeepney.info
+++ b/python/python-jeepney/python-jeepney.info
@@ -1,10 +1,10 @@
PRGNAM="python-jeepney"
-VERSION="0.7.1"
+VERSION="0.8.0"
HOMEPAGE="https://gitlab.com/takluyver/jeepney"
-DOWNLOAD="https://files.pythonhosted.org/packages/09/0d/81744e179cf3aede2d117c20c6d5b97a62ffe16b2ca5d856e068e81c7a68/jeepney-0.7.1.tar.gz"
-MD5SUM="d804ad938b27d9b761f2c44f8d33fef6"
+DOWNLOAD="https://files.pythonhosted.org/packages/d6/f4/154cf374c2daf2020e05c3c6a03c91348d59b23c5366e968feb198306fdf/jeepney-0.8.0.tar.gz"
+MD5SUM="7e2151e9197c751ceca6550bc6b3294c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-build python3-wheel"
MAINTAINER="Andrew Clemons"
EMAIL="andrew.clemons@gmail.com"