summaryrefslogtreecommitdiffstats
path: root/python/python-gflags
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-gflags')
-rw-r--r--python/python-gflags/python-gflags.SlackBuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/python/python-gflags/python-gflags.SlackBuild b/python/python-gflags/python-gflags.SlackBuild
index 852efea8a2..56f3c4eb69 100644
--- a/python/python-gflags/python-gflags.SlackBuild
+++ b/python/python-gflags/python-gflags.SlackBuild
@@ -57,6 +57,11 @@ find -L . \
python setup.py install --root=$PKG
+# Add Python3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true