summaryrefslogtreecommitdiffstats
path: root/python/python-d2to1
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-d2to1')
-rw-r--r--python/python-d2to1/README5
-rw-r--r--python/python-d2to1/python-d2to1.SlackBuild102
-rw-r--r--python/python-d2to1/python-d2to1.info10
-rw-r--r--python/python-d2to1/slack-desc19
4 files changed, 0 insertions, 136 deletions
diff --git a/python/python-d2to1/README b/python/python-d2to1/README
deleted file mode 100644
index 68e7d7c3a4..0000000000
--- a/python/python-d2to1/README
+++ /dev/null
@@ -1,5 +0,0 @@
-python-d2to1 (distutils2 setup.cfg for distribute/setuptools)
-
-d2to1 (the 'd' is for 'distutils') allows using distutils2-like
-setup.cfg files for a package’s metadata with a distribute/setuptools
-setup.py script.
diff --git a/python/python-d2to1/python-d2to1.SlackBuild b/python/python-d2to1/python-d2to1.SlackBuild
deleted file mode 100644
index 48ec61f461..0000000000
--- a/python/python-d2to1/python-d2to1.SlackBuild
+++ /dev/null
@@ -1,102 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python-d2to1
-
-# Copyright 2017 David Spencer, Baildon, West Yorkshire, U.K.
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python-d2to1
-VERSION=${VERSION:-0.2.12.post1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- rm -rf build
- python3 setup.py install --root=$PKG
-fi
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst CONTRIBUTORS LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-d2to1/python-d2to1.info b/python/python-d2to1/python-d2to1.info
deleted file mode 100644
index e9f0875e3c..0000000000
--- a/python/python-d2to1/python-d2to1.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-d2to1"
-VERSION="0.2.12.post1"
-HOMEPAGE="https://pypi.python.org/pypi/d2to1/"
-DOWNLOAD="https://pypi.python.org/packages/dc/bd/eac45e4e77d76f6c0ae539819c40f1babb891d7855129663e37957a7c2df/d2to1-0.2.12.post1.tar.gz"
-MD5SUM="1ba7e64ead23cbf104993122f0871030"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="David Spencer"
-EMAIL="baildon.research@googlemail.com"
diff --git a/python/python-d2to1/slack-desc b/python/python-d2to1/slack-desc
deleted file mode 100644
index b09c7d58b7..0000000000
--- a/python/python-d2to1/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-d2to1: python-d2to1 (distutils2 setup.cfg for distribute/setuptools)
-python-d2to1:
-python-d2to1: d2to1 (the 'd' is for 'distutils') allows using distutils2-like
-python-d2to1: setup.cfg files for a package's metadata with a distribute/setuptools
-python-d2to1: setup.py script.
-python-d2to1:
-python-d2to1: https://pypi.python.org/pypi/d2to1/
-python-d2to1:
-python-d2to1:
-python-d2to1:
-python-d2to1: