summaryrefslogtreecommitdiffstats
path: root/python/python-argopt/python-argopt.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python-argopt/python-argopt.SlackBuild')
-rw-r--r--python/python-argopt/python-argopt.SlackBuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/python/python-argopt/python-argopt.SlackBuild b/python/python-argopt/python-argopt.SlackBuild
index 6f749447e5..e5240410b8 100644
--- a/python/python-argopt/python-argopt.SlackBuild
+++ b/python/python-argopt/python-argopt.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for python-argopt
# Copyright 2018-2021 Andrew Clemons, Wellington New Zealand
+# Copyright 2022-2023 Andrew Clemons, Tokyo Japan
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-argopt
SRCNAM="$(echo "$PRGNAM" | cut -d- -f2)"
-VERSION=${VERSION:-0.7.0}
+VERSION=${VERSION:-0.8.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,7 +78,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \