summaryrefslogtreecommitdiffstats
path: root/python/pysetuptools/pysetuptools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pysetuptools/pysetuptools.SlackBuild')
-rw-r--r--python/pysetuptools/pysetuptools.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/python/pysetuptools/pysetuptools.SlackBuild b/python/pysetuptools/pysetuptools.SlackBuild
index f3a3f266ae..e819e8e03d 100644
--- a/python/pysetuptools/pysetuptools.SlackBuild
+++ b/python/pysetuptools/pysetuptools.SlackBuild
@@ -21,7 +21,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pysetuptools
-VERSION=${VERSION:-0.8}
+VERSION=${VERSION:-0.9.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -58,6 +58,11 @@ find -L . \
rm -f setuptools/*.exe
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \;