summaryrefslogtreecommitdiffstats
path: root/python/pysass
diff options
context:
space:
mode:
Diffstat (limited to 'python/pysass')
-rw-r--r--python/pysass/pysass.SlackBuild12
-rw-r--r--python/pysass/pysass.info2
2 files changed, 4 insertions, 10 deletions
diff --git a/python/pysass/pysass.SlackBuild b/python/pysass/pysass.SlackBuild
index 1e80556325..4535032745 100644
--- a/python/pysass/pysass.SlackBuild
+++ b/python/pysass/pysass.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pysass
SRCPKG=${SRCPKG-pysass}
VERSION=${VERSION:-0.1.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,15 +41,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -68,10 +65,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/pysass/pysass.info b/python/pysass/pysass.info
index 915f9632f6..3ea0f316c6 100644
--- a/python/pysass/pysass.info
+++ b/python/pysass/pysass.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://files.pythonhosted.org/packages/bc/9c/b1661c74c79949fa5dce5c67
MD5SUM="b54e9064102cbe40a1f75f8b7ffa9d4f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-libsass python-watchdog BeautifulSoup4"
+REQUIRES="python3-libsass python3-watchdog BeautifulSoup4"
MAINTAINER="Prof. HORSTMANN"
EMAIL="wmh@eipg.fr"