summaryrefslogtreecommitdiffstats
path: root/python/pyperclip/pyperclip.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyperclip/pyperclip.SlackBuild')
-rw-r--r--python/pyperclip/pyperclip.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/pyperclip/pyperclip.SlackBuild b/python/pyperclip/pyperclip.SlackBuild
index 2b7cac0b17..be7fd3b001 100644
--- a/python/pyperclip/pyperclip.SlackBuild
+++ b/python/pyperclip/pyperclip.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyperclip
-# Copyright 2015 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2015-2016 Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
# PDF Documentation downloaded from pyperclip.readthedocs.org 12/1/2015
PRGNAM=pyperclip
-VERSION=${VERSION:-1.5.25}
+VERSION=${VERSION:-1.5.27}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -74,6 +74,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true