summaryrefslogtreecommitdiffstats
path: root/python/pyotp
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyotp')
-rw-r--r--python/pyotp/pyotp.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/python/pyotp/pyotp.SlackBuild b/python/pyotp/pyotp.SlackBuild
index d7779e30ad..30f13eee70 100644
--- a/python/pyotp/pyotp.SlackBuild
+++ b/python/pyotp/pyotp.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyotp
-# Copyright 2018 Dominik Drobek <dominik.drobek (at) o2.pl>
+# Copyright 2018, 2019 Dominik Drobek <dominik.drobek (at) o2.pl>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pyotp
VERSION=${VERSION:-2.2.7}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -71,6 +71,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a Changes.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild