summaryrefslogtreecommitdiffstats
path: root/python/pyinotify/pyinotify.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyinotify/pyinotify.SlackBuild')
-rw-r--r--python/pyinotify/pyinotify.SlackBuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/python/pyinotify/pyinotify.SlackBuild b/python/pyinotify/pyinotify.SlackBuild
index 342ac21cb5..07212a8d06 100644
--- a/python/pyinotify/pyinotify.SlackBuild
+++ b/python/pyinotify/pyinotify.SlackBuild
@@ -5,7 +5,7 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=pyinotify
-VERSION=${VERSION:-0.9.0}
+VERSION=${VERSION:-0.9.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -27,9 +27,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM
+rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM
+cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -37,13 +37,20 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Compile the C extension.
+sed -i '/^compile_ext_mod/s|=.*|= True|' setup.py
+
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ACKS ChangeLog_old COPYING NEWS_old $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ACKS COPYING PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install