summaryrefslogtreecommitdiffstats
path: root/python/pygsl
diff options
context:
space:
mode:
Diffstat (limited to 'python/pygsl')
-rw-r--r--python/pygsl/pygsl.SlackBuild8
-rw-r--r--python/pygsl/pygsl.info6
-rw-r--r--python/pygsl/remove_swig_dep_for_gls_wrappers.patch50
3 files changed, 5 insertions, 59 deletions
diff --git a/python/pygsl/pygsl.SlackBuild b/python/pygsl/pygsl.SlackBuild
index 96c7c6366e..6d87916a68 100644
--- a/python/pygsl/pygsl.SlackBuild
+++ b/python/pygsl/pygsl.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for PyGSL
# Based on the Slackware 15.0 SlackBuild
#
-# Copyright 2017-2022, Fellype do Nascimento, Guaratinguetá - Brazil
+# Copyright 2017-2023, Fellype do Nascimento, Guaratinguetá - Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pygsl
-VERSION=${VERSION:-2.3.2}
+VERSION=${VERSION:-2.3.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,10 +80,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Patch setup.py in order to remove (unneeded) dependency on swig to re-generate GSL wrappers
-# thanks to FreeBSD ports https://cgit.freebsd.org/ports/tree/math/py-pygsl/files/patch-setup.py
-patch -p1 < $CWD/remove_swig_dep_for_gls_wrappers.patch setup.py
-
python3 setup.py config
python3 setup.py build
python3 setup.py install --root=$PKG --prefix=/usr
diff --git a/python/pygsl/pygsl.info b/python/pygsl/pygsl.info
index 18120e2708..76dde88313 100644
--- a/python/pygsl/pygsl.info
+++ b/python/pygsl/pygsl.info
@@ -1,8 +1,8 @@
PRGNAM="pygsl"
-VERSION="2.3.2"
+VERSION="2.3.3"
HOMEPAGE="https://github.com/pygsl/pygsl/"
-DOWNLOAD="https://files.pythonhosted.org/packages/0f/82/8bc81042923e474de30a080a551f11a4a352c098a569e6e126f313322735/pygsl-2.3.2.tar.gz"
-MD5SUM="d5b0af1a53cba081977ead7d0cdc221e"
+DOWNLOAD="https://files.pythonhosted.org/packages/15/f4/139020a271ebd4dd25b8db53edca042d49890bda53587a904e0fa75310b0/pygsl-2.3.3.tar.gz"
+MD5SUM="348c64a43d9bc547b092a00930c1c005"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-numpy"
diff --git a/python/pygsl/remove_swig_dep_for_gls_wrappers.patch b/python/pygsl/remove_swig_dep_for_gls_wrappers.patch
deleted file mode 100644
index 1962d829dd..0000000000
--- a/python/pygsl/remove_swig_dep_for_gls_wrappers.patch
+++ /dev/null
@@ -1,50 +0,0 @@
---- pygsl-2.3.2/setup.py 2021-12-07 13:05:38.000000000 -0300
-+++ pygsl-2.3.2/setup.py.new 2022-04-14 22:17:19.153861777 -0300
-@@ -89,8 +89,6 @@
- gsldist_path = os.path.join(pygsldir, "gsl_dist")
- sys.path.insert(0, gsldist_path)
-
--from wheel.bdist_wheel import bdist_wheel as _bdist_wheel
--
- import setuptools
- import setuptools.command
- import setuptools.command.install
-@@ -173,26 +171,6 @@
- del t_file
-
-
--class CustomInstallCommand(setuptools.command.install.install):
-- def run(self):
-- # first re-generate GSL wrappers using SWIG
-- self.run_command('gsl_wrappers')
-- # then configure
-- self.run_command('config')
-- # then install
-- setuptools.command.install.install.run(self)
-- #super().run()
--
--class CustomBdistWheelCommand(_bdist_wheel):
-- def run(self):
-- # first re-generate GSL wrappers using SWIG
-- self.run_command('gsl_wrappers')
-- # then configure
-- self.run_command('config')
-- # then install
-- _bdist_wheel.run(self)
-- #super().run()
--
- py_module_names = ['errors',
- 'statistics.__init__',
- '_numobj',
-@@ -270,10 +248,9 @@
- ext_package = 'pygsl',
- ext_modules = exts,
- headers = headers,
-- cmdclass = {'bdist_wheel': CustomBdistWheelCommand,
-+ cmdclass = {
- 'config' : gsl_Config_Path,
- 'gsl_wrappers': gsl_CodeGenerator.gsl_CodeGenerator,
-- 'install': CustomInstallCommand,
- #'build_sphinx': BuildDoc
- },
- install_requires = ['numpy'],