summaryrefslogtreecommitdiffstats
path: root/python/pygsl/pygsl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pygsl/pygsl.SlackBuild')
-rw-r--r--python/pygsl/pygsl.SlackBuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/python/pygsl/pygsl.SlackBuild b/python/pygsl/pygsl.SlackBuild
index 96c7c6366e..6d87916a68 100644
--- a/python/pygsl/pygsl.SlackBuild
+++ b/python/pygsl/pygsl.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for PyGSL
# Based on the Slackware 15.0 SlackBuild
#
-# Copyright 2017-2022, Fellype do Nascimento, Guaratinguetá - Brazil
+# Copyright 2017-2023, Fellype do Nascimento, Guaratinguetá - Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pygsl
-VERSION=${VERSION:-2.3.2}
+VERSION=${VERSION:-2.3.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,10 +80,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Patch setup.py in order to remove (unneeded) dependency on swig to re-generate GSL wrappers
-# thanks to FreeBSD ports https://cgit.freebsd.org/ports/tree/math/py-pygsl/files/patch-setup.py
-patch -p1 < $CWD/remove_swig_dep_for_gls_wrappers.patch setup.py
-
python3 setup.py config
python3 setup.py build
python3 setup.py install --root=$PKG --prefix=/usr