summaryrefslogtreecommitdiffstats
path: root/python/pygame
diff options
context:
space:
mode:
Diffstat (limited to 'python/pygame')
-rw-r--r--python/pygame/README5
-rw-r--r--python/pygame/pygame.SlackBuild113
-rw-r--r--python/pygame/pygame.info10
-rw-r--r--python/pygame/setup.patch21
-rw-r--r--python/pygame/slack-desc19
5 files changed, 0 insertions, 168 deletions
diff --git a/python/pygame/README b/python/pygame/README
deleted file mode 100644
index 653401ddde..0000000000
--- a/python/pygame/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Pygame is a set of Python modules designed for writing games. It is
-written on top of the excellent SDL library. This allows you to create
-fully featured games and multimedia programs in the python language.
-Pygame is highly portable and runs on nearly every platform and
-operating system.
diff --git a/python/pygame/pygame.SlackBuild b/python/pygame/pygame.SlackBuild
deleted file mode 100644
index e5a792a8fe..0000000000
--- a/python/pygame/pygame.SlackBuild
+++ /dev/null
@@ -1,113 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pygame
-
-## Written by hollywoodb (hollywoodb@fastmail.fm)
-# Modified by the SlackBuilds.org project
-# Maintained by Bojan Popovic (bocke@slackware-srbija.org), 2014-2017
-# Contribution by B.Watson (urchlay@slackware.uk), 11 apr. 2017.
-# Copyright 2017-2022 Dimitris Zlatanidis Orestiada, Greece
-#
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pygame
-VERSION=${VERSION:-2.0.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-else
- SLKCFLAGS="-O2"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-patch -p1 < $CWD/setup.patch
-
-# Since portmidi 2.0.2, libporttime is included in libportmidi.
-# Therfore use config-settings like for Fedora.
-sed -i 's;/etc/redhat-release;/etc/slackware-version;' buildconfig/config_unix.py
-
-# Contributed by B.Watson (urchlay@slackware.uk).
-# Gets rid of the call to remove_old_files() during packaging.
-# TLDR: Stops packaging scripts from messing with a local PyGame install.
-sed -i '/^if "install"/,$d' setup.py
-
-# Pygame version 2.0.3 is the last that supports python2
-python2 -u buildconfig/config.py
-CFLAGS="$SLKCFLAGS" \
-python2 setup.py install --root=$PKG
-
- CFLAGS="$SLKCFLAGS" \
-python3 setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst docs/LGPL.txt docs/README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pygame/pygame.info b/python/pygame/pygame.info
deleted file mode 100644
index 883b018c04..0000000000
--- a/python/pygame/pygame.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pygame"
-VERSION="2.0.3"
-HOMEPAGE="http://www.pygame.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/47/a6/bd02c7354ac7e975e52443a24dbd0be8d071c59b75d54db9dfa87cd2979f/pygame-2.0.3.tar.gz"
-MD5SUM="04e082d216b3b771b8d52769597b2fb2"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="portmidi"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/pygame/setup.patch b/python/pygame/setup.patch
deleted file mode 100644
index 687c758874..0000000000
--- a/python/pygame/setup.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- pygame-2.0.3/setup.orig 2022-02-20 22:52:08.449183353 +0200
-+++ pygame-2.0.3/setup.py 2022-02-20 22:52:57.916188118 +0200
-@@ -75,7 +75,7 @@
-
-
- # A (bit hacky) fix for https://github.com/pygame/pygame/issues/2613
--# This is due to the fact that distutils uses command line args to
-+# This is due to the fact that distutils uses command line args to
- # export PyInit_* functions on windows, but those functions are already exported
- # and that is why compiler gives warnings
- from distutils.command.build_ext import build_ext
-@@ -95,6 +95,9 @@
- the_system = 'Ubuntu'
- elif distro[0].lower() == 'debian':
- the_system = 'Debian'
-+ elif distro[0].lower() == 'slackware':
-+ the_system = 'Slackware'
-+
-
- help_urls = {
- 'Linux': 'https://www.pygame.org/wiki/Compilation',
diff --git a/python/pygame/slack-desc b/python/pygame/slack-desc
deleted file mode 100644
index f911b71e85..0000000000
--- a/python/pygame/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pygame: pygame (a set of Python modules designed for writing games)
-pygame:
-pygame: pygame is written on top of the excellent SDL library. This allows you
-pygame: to create fully featured games and multimedia programs in the python
-pygame: language. Pygame is highly portable and runs on nearly every platform
-pygame: and operating system.
-pygame:
-pygame: Pygame is free. Released under the LGPL licence, you can create open
-pygame: source, free, freeware, shareware, and commercial games with it.
-pygame:
-pygame: Homepage: http://www.pygame.org/