summaryrefslogtreecommitdiffstats
path: root/python/pycryptopp
diff options
context:
space:
mode:
Diffstat (limited to 'python/pycryptopp')
-rw-r--r--python/pycryptopp/README2
-rw-r--r--python/pycryptopp/pycryptopp-0.7.1-abi-change.patch55
-rw-r--r--python/pycryptopp/pycryptopp.SlackBuild113
-rw-r--r--python/pycryptopp/pycryptopp.info10
-rw-r--r--python/pycryptopp/slack-desc19
5 files changed, 0 insertions, 199 deletions
diff --git a/python/pycryptopp/README b/python/pycryptopp/README
deleted file mode 100644
index e7f2e1e44a..0000000000
--- a/python/pycryptopp/README
+++ /dev/null
@@ -1,2 +0,0 @@
-pycryptopp is a set of Python wrappers for a few of the best crypto
-algorithms from the Crypto++ library.
diff --git a/python/pycryptopp/pycryptopp-0.7.1-abi-change.patch b/python/pycryptopp/pycryptopp-0.7.1-abi-change.patch
deleted file mode 100644
index d6edd2ecc6..0000000000
--- a/python/pycryptopp/pycryptopp-0.7.1-abi-change.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-https://github.com/tahoe-lafs/pycryptopp/issues/42
-
---- old/src/pycryptopp/cipher/aesmodule.cpp
-+++ old/src/pycryptopp/cipher/aesmodule.cpp
-@@ -20,6 +20,8 @@
- #include <src-cryptopp/aes.h>
- #endif
-
-+typedef unsigned char byte;
-+
- static const char*const aes___doc__ = "_aes counter mode cipher\n\
- You are advised to run aes.start_up_self_test() after importing this module.";
-
---- old/src/pycryptopp/cipher/xsalsa20module.cpp
-+++ old/src/pycryptopp/cipher/xsalsa20module.cpp
-@@ -16,6 +16,8 @@
- #include <src-cryptopp/salsa.h>
- #endif
-
-+typedef unsigned char byte;
-+
- static const char* const xsalsa20__doc__ = "_xsalsa20 cipher";
-
- static PyObject *xsalsa20_error;
---- old/src/pycryptopp/hash/sha256module.cpp
-+++ old/src/pycryptopp/hash/sha256module.cpp
-@@ -21,6 +21,8 @@
- #include <src-cryptopp/filters.h>
- #endif
-
-+typedef unsigned char byte;
-+
- static const char*const sha256___doc__ = "_sha256 hash function";
-
- static PyObject *sha256_error;
---- old/src/pycryptopp/publickey/rsamodule.cpp
-+++ old/src/pycryptopp/publickey/rsamodule.cpp
-@@ -87,7 +87,7 @@
- VerifyingKey_serialize(VerifyingKey *self, PyObject *dummy) {
- std::string outstr;
- StringSink ss(outstr);
-- self->k->DEREncode(ss);
-+ self->k->GetMaterial().Save(ss);
- PyStringObject* result = reinterpret_cast<PyStringObject*>(PyString_FromStringAndSize(outstr.c_str(), outstr.size()));
- if (!result)
- return NULL;
-@@ -216,7 +216,7 @@
- SigningKey_serialize(SigningKey *self, PyObject *dummy) {
- std::string outstr;
- StringSink ss(outstr);
-- self->k->DEREncode(ss);
-+ self->k->GetMaterial().Save(ss);
- PyStringObject* result = reinterpret_cast<PyStringObject*>(PyString_FromStringAndSize(outstr.c_str(), outstr.size()));
- if (!result)
- return NULL;
diff --git a/python/pycryptopp/pycryptopp.SlackBuild b/python/pycryptopp/pycryptopp.SlackBuild
deleted file mode 100644
index 70ae017884..0000000000
--- a/python/pycryptopp/pycryptopp.SlackBuild
+++ /dev/null
@@ -1,113 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pycryptopp
-
-# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2012-2016 Markus Reichelt, Aachen, DE
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Originally written by Marco Bonetti - Thanks!
-# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pycryptopp
-VERSION=${VERSION:-0.7.1.869544967005693312591928092448767568728501330214}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-# thanks arch maintainers
-patch -p1 -i $CWD/pycryptopp-0.7.1-abi-change.patch
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-export PYCRYPTOPP_DISABLE_EMBEDDED_CRYPTOPP=1
-
-CFLAGS="$SLKCFLAGS -fno-strict-aliasing" \
-CXXFLAGS="$SLKCFLAGS -fno-strict-aliasing" \
-python setup.py build
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING* NEWS* README* copyright \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-#cleanup
-rm $PKG/usr/share/doc/pycryptopp/*
-cd $PKG/usr
-rmdir -p share/doc/pycryptopp
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pycryptopp/pycryptopp.info b/python/pycryptopp/pycryptopp.info
deleted file mode 100644
index 63de74b596..0000000000
--- a/python/pycryptopp/pycryptopp.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pycryptopp"
-VERSION="0.7.1.869544967005693312591928092448767568728501330214"
-HOMEPAGE="https://pypi.python.org/pypi/pycryptopp"
-DOWNLOAD="https://pypi.python.org/packages/7c/e2/7e035d306c7516c471802d7cd7b6c1e403e582489bc5c14706854a187a24/pycryptopp-0.7.1.869544967005693312591928092448767568728501330214.tar.gz"
-MD5SUM="9df81282f05400b3d19e1dd4cb424553"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="darcsver"
-MAINTAINER="Markus Reichelt"
-EMAIL="slackbuilds@mareichelt.de"
diff --git a/python/pycryptopp/slack-desc b/python/pycryptopp/slack-desc
deleted file mode 100644
index 6ce7ebb14a..0000000000
--- a/python/pycryptopp/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pycryptopp: pycryptopp (Python wrappers for Crypto++)
-pycryptopp:
-pycryptopp: pycryptopp is a set of Python wrappers for a few of the best crypto
-pycryptopp: algorithms from the Crypto++ library.
-pycryptopp:
-pycryptopp: Homepage: https://pypi.python.org/pypi/pycryptopp
-pycryptopp:
-pycryptopp:
-pycryptopp:
-pycryptopp:
-pycryptopp: