summaryrefslogtreecommitdiffstats
path: root/python/pycodestyle/pycodestyle.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pycodestyle/pycodestyle.SlackBuild')
-rw-r--r--python/pycodestyle/pycodestyle.SlackBuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/python/pycodestyle/pycodestyle.SlackBuild b/python/pycodestyle/pycodestyle.SlackBuild
index 17d374742a..8955e1a998 100644
--- a/python/pycodestyle/pycodestyle.SlackBuild
+++ b/python/pycodestyle/pycodestyle.SlackBuild
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pycodestyle
-VERSION=${VERSION:-2.0.0}
+VERSION=${VERSION:-2.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -69,10 +69,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Fix permissions for docs and python egg-info folder
-chmod 0755 -R docs $PRGNAM.egg-info
-
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \