summaryrefslogtreecommitdiffstats
path: root/python/pyOpenSSL/pyOpenSSL.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyOpenSSL/pyOpenSSL.SlackBuild')
-rw-r--r--python/pyOpenSSL/pyOpenSSL.SlackBuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/python/pyOpenSSL/pyOpenSSL.SlackBuild b/python/pyOpenSSL/pyOpenSSL.SlackBuild
index 22e160ec69..03a3265baf 100644
--- a/python/pyOpenSSL/pyOpenSSL.SlackBuild
+++ b/python/pyOpenSSL/pyOpenSSL.SlackBuild
@@ -4,6 +4,7 @@
#
# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
# Copyright 2012-2018 Markus Reichelt, Aachen, DE
+# Copyright 2022-2024 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,12 +25,12 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
# Originally written by Marco Bonetti - Thanks!
-# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
+# Maintained by Markus Reichelt <slackbuilds@mareichelt.de> until 2022
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pyOpenSSL
-VERSION=${VERSION:-17.5.0}
+VERSION=${VERSION:-24.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -42,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -84,14 +82,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -ar *.rst LICENSE doc/ examples/ $PKG/usr/doc/$PRGNAM-$VERSION
+cp -ar *.rst LICENSE doc/ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install