summaryrefslogtreecommitdiffstats
path: root/python/ps_mem/ps_mem.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/ps_mem/ps_mem.SlackBuild')
-rw-r--r--python/ps_mem/ps_mem.SlackBuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/python/ps_mem/ps_mem.SlackBuild b/python/ps_mem/ps_mem.SlackBuild
index c939b3ec48..fea92978b6 100644
--- a/python/ps_mem/ps_mem.SlackBuild
+++ b/python/ps_mem/ps_mem.SlackBuild
@@ -2,7 +2,7 @@
#
# Slackware build script for ps_mem.
#
-# Copyright 2015-2018 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# Copyright 2015-2022 Edinaldo P. Silva, Rio de Janeiro, Brazil.
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ps_mem
-VERSION=${VERSION:-3.13}
+VERSION=${VERSION:-3.14}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -64,16 +64,14 @@ else
LIBDIRSUFFIX=""
fi
-SRCVER=${SRCVER:-9f54e1aa3a87ec176ce8b71f02673e0d8293b344}
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$SRCVER
-tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
-cd $PRGNAM-$SRCVER
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -81,7 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG --optimize=1
+python3 setup.py install --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true