summaryrefslogtreecommitdiffstats
path: root/python/progressive/progressive.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/progressive/progressive.SlackBuild')
-rw-r--r--python/progressive/progressive.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/python/progressive/progressive.SlackBuild b/python/progressive/progressive.SlackBuild
index 7ce7329782..6590175f8a 100644
--- a/python/progressive/progressive.SlackBuild
+++ b/python/progressive/progressive.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for progressive
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=progressive
-VERSION=${VERSION:-0.3.3}
+VERSION=${VERSION:-0.3.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,7 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true