summaryrefslogtreecommitdiffstats
path: root/python/polib
diff options
context:
space:
mode:
Diffstat (limited to 'python/polib')
-rw-r--r--python/polib/README4
-rw-r--r--python/polib/polib.SlackBuild5
2 files changed, 9 insertions, 0 deletions
diff --git a/python/polib/README b/python/polib/README
index 69123d0da4..65bbcbef9a 100644
--- a/python/polib/README
+++ b/python/polib/README
@@ -8,4 +8,8 @@ from scratch.
polib supports out of the box any version of python ranging from
2.4 to latest 3.X version.
+To install python3 bindings run the slackbuild with PYTHON3=yes.
+
+ # PYTHON3=yes ./polib.SlackBuild
+
Optional dependency: Sphinx
diff --git a/python/polib/polib.SlackBuild b/python/polib/polib.SlackBuild
index 397e8e2090..a57a216cb2 100644
--- a/python/polib/polib.SlackBuild
+++ b/python/polib/polib.SlackBuild
@@ -66,6 +66,11 @@ find -L . \
python setup.py install --root=$PKG
+# Install python3 bindings for polib. Default is no.
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true